> + if (IS_A_NUMBER(args[optind])) { wouldn't it be easier to simply add if (!IS_A_NUMBER(args[optind])) { optind++; continue; } instead of moving the whole body of the loop inside the if-block. Or did I miss something?