Jeff Moyer wrote:
==> Regarding Re: [Crash-utility] crash version 4.0-2.11 is
available; Dave Anderson <anderson(a)redhat.com> adds:
>>
>> "kmem_cache_s" got renamed to "kmem_cache" in the latest git
:( Time to
>> update crash again .. :(
anderson> Hopefully it's just a name change (again...) without other
anderson> changes that will require a new kmem "version" within crash.
Here's the git log:
Author: Pekka J Enberg <penberg(a)cs.Helsinki.FI>
Date: Mon Nov 7 00:58:01 2005 -0800
[PATCH] mm: rename kmem_cache_s to kmem_cache
This patch renames struct kmem_cache_s to kmem_cache so we can start using
it instead of kmem_cache_t typedef.
Signed-off-by: Pekka Enberg <penberg(a)cs.helsinki.fi>
Signed-off-by: Andrew Morton <akpm(a)osdl.org>
Signed-off-by: Linus Torvalds <torvalds(a)osdl.org>
Sounds like just a name change to me.
-Jeff
Thanks -- googling that commit shows this as the only change to slab.c:
--- 2.6.orig/mm/slab.c
+++ 2.6/mm/slab.c
@@ -368,7 +368,7 @@ static inline void kmem_list3_init(struc
* manages a cache.
*/
-struct kmem_cache_s {
+struct kmem_cache {
/* 1) per-cpu data, touched during every alloc/free */
struct array_cache *array[NR_CPUS];
unsigned int batchcount;
Phew...